Below is the list of requirements your server should meet to get our script running smoothly. You can also download this script, execute it on your server and let it check your server automatically.

Server

Unix-type or Windows

PHP

Versions 5.1.0 or later

PHP Extensions

  • Reflection extension
  • PCRE extension
  • SPL extension
  • PDO MySQL extension
  • GD extension with gif/jpeg read/write and FreeType support
  • CURL extension

PHP Settings

  • Memory limit >= 32M
  • .htaccess and mod_rewrite enabled

MySQL

Version 4.1 or later

Cron Jobs

The ability to create cron jobs (scheduled tasks) is available on most hosts, including shared ones. This is not a mandatory requirement, but recommended. If there's no ability to run crons on your server you will still be able to execute them manually from an admin panel.

Get Your Couponic!